Задать вопрос
26 июня, 07:17

Дан одномерный массив: 8, 3, - 9, 10, 0. Отсортировать элементы массива по убыванию.

+3
Ответы (1)
  1. 26 июня, 07:52
    0
    Uses crt;

    const n=5;

    var a:array[1 ... n] of integer;

    i, p:integer;

    begin

    for i:=1 to n do

    read (a[i]) ;

    repeat

    p:=0;

    for i:=1 to n-1 do

    if a[i]
    begin

    p:=1;

    a[i]:=a[i]+a[i+1];

    a[i+1]:=a[i]-a[i+1];

    a[i]:=a[i]-a[i+1];

    end;

    until p=0;

    for i:=1 to n do

    writeln (a[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан одномерный массив: 8, 3, - 9, 10, 0. Отсортировать элементы массива по убыванию. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан массив целых чисел в диапазоне от - 30000 до 30000. Отсортировать его по убыванию. Методом простого выбора. Формат ввода: В первой строке - количество элементов массива не превосходящее 100. На второй строке через пробел элементы массива.
Ответы (1)