Задать вопрос
18 февраля, 08:44

Дана последовательность целых чисел, признаком конца которой служит 0. 0 не входит в последовательность. Найти среднеарифметическое элементов последовательности. Напишите программу

+4
Ответы (1)
  1. 18 февраля, 11:25
    0
    Program n1;

    var a, sum, k: integer;

    begin

    readln (a) ;

    sum:=0;

    k:=0;

    while a0 do

    begin

    sum:=sum+a;

    k:=k+1;

    readln (a) ;

    end;

    writeln (sum/k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана последовательность целых чисел, признаком конца которой служит 0. 0 не входит в последовательность. Найти среднеарифметическое ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы