Задать вопрос
9 ноября, 01:41

1) Составьте программу вычисления произведения S=1*2+3*4+5*6 + ... + 101*102 (в паскале)

2) составьте программу вычисления суммы S=0.5+1.5+2.5 + ... + 98.5+99.5

+4
Ответы (1)
  1. 9 ноября, 04:36
    0
    1)

    var

    com, i:integer;

    begin

    for i: = 1 to 101 do

    if i mod 2 = 1 then

    com: = com + i * i+1;

    Writeln (com) ;

    end.

    Результат:

    176902

    2)

    var

    sum, x:Real;

    begin

    while x < 100 do begin

    sum : = sum + x;

    x: = x + 0.5

    end;

    Writeln (sum) ;

    end.

    Результат:

    9950
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Составьте программу вычисления произведения S=1*2+3*4+5*6 + ... + 101*102 (в паскале) 2) составьте программу вычисления суммы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы