Задать вопрос
23 июня, 17:18

Задача в Pascal!

Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.

Входные данные:

Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D < = 1000).

Выходные данные:

Вывести единственное число.

Пример входного файла (input. txt) :

10 1 1 2 3

+5
Ответы (1)
  1. 23 июня, 19:16
    0
    Var

    A, B, C, D, N, V, K, M: integer;

    F: Text;

    begin

    Assign (f,'input. txt') ;

    Reset (f) ;

    Readln (N, A, B, C, D) ;

    Close (f) ;

    V : = A * B * N;

    if V mod C 0 then

    K : = V div C + 1

    else

    K : = V div C;

    if K mod D 0 then

    M : = K div D + 1

    else

    M : = K div D;

    writeln (M)

    end.

    Тестовое решение:

    2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача в Pascal! Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы