Задать вопрос
28 января, 05:57

Составить программу на паскале. Вычислить корни квадратного

уравнения, заданного коэффициентами A, B,

C (предполагается, что а0 и что дискриминант

уравнения неотрицателен)

+3
Ответы (1)
  1. 28 января, 07:01
    0
    Var a, b, c, D, x1, x2:real;

    begin

    write ('Введите коэффициенты a, b, c: ') ;

    readln (a, b, c) ;

    D: = b*b-4*a*c;

    if D>0 then

    begin

    x1: = (-b-sqrt (D)) / 2/a;

    x2: = (-b+sqrt (D)) / 2/a;

    writeln ('Два корня: ', x1,' и ', x2)

    end;

    if D=0 then

    begin

    x1:=-b/2/a;

    writeln ('Один корень: ', x1)

    end;

    if D<0 then writeln ('Корней нет')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на паскале. Вычислить корни квадратного уравнения, заданного коэффициентами A, B, C (предполагается, что а0 и что ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы