Задать вопрос
26 марта, 22:58

Написать программу, которая вычисляет факториал числа.

+3
Ответы (2)
  1. 27 марта, 01:15
    0
    Var n, f, i: integer;

    begin

    write ('n = ') ;

    readln (n) ;

    f:=1;

    for i:=1 to n do f:=f*i;

    writeln (n,'! = ', f) ;

    end.

    Пример:

    n = 6

    6! = 720
  2. 27 марта, 01:56
    0
    Program E9;

    var p, i, n: integer;

    begin

    write ('введите целое n = ') ;

    readln (n) ;

    p: = 1;

    for i: = 1 to n do

    p: = p * i;

    write (n, '! = ', p) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вычисляет факториал числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы