Задать вопрос
10 сентября, 21:26

Дано квадратное уравнение вида A*x^2+B*x+C=0

Коэффициенты заданы A = 4.00 B = - 52.00 C = 144.00

A>0, D>0. Формулы для помощи: d=B^2 - 4*a*c; x1,2 = (-b + - Sqrt (d)) / (2*a)

Вывести вначале меньший корень, затем больший.

Нужно написать программу в Pascal'e.

+4
Ответы (1)
  1. 11 сентября, 00:19
    0
    Как-то так крч=)

    program z1;

    var a, b, c, d, x1, x2:real;

    begin

    a:=4.00;

    b:=-52.00;

    c:=144.00;

    d:=b*b - 4*a*c;

    x1: = (-b + Sqrt (d)) / (2*a) ;

    x2: = (-b - Sqrt (d)) / (2*a) ;

    if x1>x2 then begin

    writeln ('Меньший корень', x2,'Больший корень', x1)

    end else

    writeln ('Меньший корень ', x1,'Больший корень ', x2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано квадратное уравнение вида A*x^2+B*x+C=0 Коэффициенты заданы A = 4.00 B = - 52.00 C = 144.00 A>0, D>0. Формулы для помощи: d=B^2 - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы