Задать вопрос
9 апреля, 10:35

Написать программу на паскале: найти разность между К и суммой всех элементов массива с нечетными индексами

+2
Ответы (1)
  1. 9 апреля, 12:04
    0
    Желательно в задании уточнять тип массива (целый, вещественный) и споособ его генерации (ввод с клавиатуры, генератор случайных чисел).

    В данной программе массив получен с помощью генератора случайных чисел

    Program raznost;

    Uses Crt;

    const n=100; {максимальный размер массива}

    var a:array[1 ... n] of integer;

    i, m:integer;

    k, s, rez:longint;

    begin

    clrscr;

    write ('Введите К: ') ;

    readln (k) ;

    write ('Введите размер массива <100: ') ;

    readln (m) ;

    randomize;

    write ('Исходный массив:')

    s:=0;

    for i:=1 to m do

    begin

    a[i]:=random (50) + 25;

    write (i:3) ;

    if (i mod 2) 0 then s:=s+a[i];

    end;

    writeln;

    rez:=k-s;

    writeln ('Разность между K и суммой всех элементов массива с нечетными индексами=', rez) ;

    readkey;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на паскале: найти разность между К и суммой всех элементов массива с нечетными индексами ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы