Задать вопрос
31 января, 00:25

Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M (включительно).

+1
Ответы (1)
  1. 31 января, 02:27
    0
    Var

    i, k, m, j:integer;

    a, b:array[1 ... 10]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (50) ;

    write (a[i]:3) ;

    end;

    writeln;

    write ('Введите k и m: ') ;

    readln (k, m) ;

    j:=m;

    for i:=k to m do

    begin

    b[j]:=a[i];

    j:=j-1;

    end;

    for i:=k to m do a[i]:=b[i];

    writeln ('Измененный массив:') ;

    for i:=1 to 10 do write (a[i]:3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером K и заканчивая элементом с номером M ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы