Задать вопрос
13 августа, 13:45

Очень нужна помощь с Паскалем!

Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.

Входные данные

Входная строка содержит три целых числа, разделённых пробелами.

Выходные данные

Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

+4
Ответы (1)
  1. 13 августа, 14:42
    0
    Var

    a, b, c, k:integer;

    Begin

    k:=1;

    Read (a, b, c) ;

    if a=b then k:=k+1;

    if b=c then k:=k+1;

    if c=a then k:=k+1;

    if k=1 then k:=0

    else

    if k=4 then k:=3;

    Write (k)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Очень нужна помощь с Паскалем! Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы