Задать вопрос
9 октября, 15:10

Pascal ABC

С помощью процедуры заменить максимальную цифру для пяти чисел на заданное число (можно для одного числа)

+4
Ответы (1)
  1. 9 октября, 16:33
    0
    Procedure DigitReplace (Source, Replaced:integer; var Result:string) ;

    var

    SourceStr, ReplacedStr:string;

    MaxDigit:char;

    PosMax, i:integer;

    begin

    Str (Source, SourceStr) ;

    Str (Replaced, ReplacedStr) ;

    MaxDigit:=' ';

    for i:=1 to Length (SourceStr) do

    if SourceStr[i]>MaxDigit then MaxDigit:=SourceStr[i];

    for i:=Length (SourceStr) downto 1 do

    if SourceStr[i]=MaxDigit then begin

    Delete (SourceStr, i, 1) ;

    Insert (ReplacedStr, SourceStr, i)

    end;

    Result:=SourceStr

    end;

    var

    n, c:integer;

    r:string;

    begin

    Write ('Введите исходное число: ') ; Readln (n) ;

    Writeln ('Введите число для замены: ') ; Readln (c) ;

    DigitReplace (n, c, r) ;

    Writeln ('Результат: ', r) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal ABC С помощью процедуры заменить максимальную цифру для пяти чисел на заданное число (можно для одного числа) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Три фирмы A, B и C решили получить максимальную прибыль по итогам года. Экономист, хорошо знавший организацию работы в этих фирмах, высказал следующие предположения: а) фирма C получит максимальную прибыль, если максимальную прибыль получит фирма B
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)