Задать вопрос
19 ноября, 07:04

Дан массив из 10 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. Надо написать на Паскале, объяснить при этом всё, ещё и блок схему надо

+5
Ответы (2)
  1. 19 ноября, 08:53
    0
    Var m:array[1 ... 10] of integer; i, max, cnt:integer;

    begin

    max : = - 1000;

    write ('Massive: ') ;

    for i : = 1 to 10 do begin

    m[i] : = random (11) - 5;

    write (m[i],' ') ;

    if m[i] > max then begin inc (cnt) ; max : = m[i]; end;

    end;

    writeln;

    writeln ('Максимальное число: ', max) ;

    writeln ('Всего максимальных чисел: ', cnt) ;

    end.
  2. 19 ноября, 10:31
    -1
    Var m:array[1 ... 10] of integer; i, max, cnt:integer;

    begin

    max : = - 1000;

    write ('Massive: ') ;

    for i : = 1 to 10 do begin

    m[i] : = random (11) - 5;

    write (m[i],' ') ;

    if m[i] > max then begin inc (cnt) ; max : = m[i]; end;

    end;

    writeln;

    writeln ('Максимальное число: ', max) ;

    writeln ('Всего максимальных чисел: ', cnt) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив из 10 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. Надо написать на Паскале, объяснить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы