Задать вопрос
24 апреля, 19:57

Язык Паскаль.

№1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, оканчивающиеся на цифру k.

№2 Дан масив целых числ. Найти в этом массиве минимальный элмент m и максимальный M. Получить в порядке возрастания все целые числа из интервала (m; M), которые не входят в данный массив.

№3 Сформировать массив простых чисел, не больших заданного натурального числа N.

№4 Сформировать массив простых множителей заданного числа.

+1
Ответы (1)
  1. 24 апреля, 20:28
    0
    1.

    const n=10;

    var a, b array [1 ... n] of integer;

    i, j, k:integer;

    begin

    readln (k) ;

    j:=0;

    for i:=1 to n do

    begin

    readln (a[i]) ;

    if (a[i] mod k=0) and (a[i]0) then

    begin

    j:=j+1;

    b[j]:=a[i];

    end;

    end;

    for i:=1 to j do

    write (b[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Язык Паскаль. №1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
дан масив из 10 целых положительных чисел, заполненный с клавиатуры. Найти максимальный и минимальный элемент в массиве и определить, на сколько максимальный элемент больше минимального.
Ответы (1)
Дан масив из 12 целых чисел вывести исходный масив и получить новый элементы которого увеличены в 4 раза
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)