Задать вопрос
23 ноября, 10:24

Составить программу (Паскаль) построения на экране n прямоугольников разного цвета, расположенных хаотично.

+3
Ответы (1)
  1. 23 ноября, 11:34
    0
    uses graph;

    var n, i, x, y, height, width:integer;

    procedure init;

    var gd, gm:integer;

    begin

    gd:=vga;

    gm:=vgahi;

    initgraph (gd, gm,'') ;

    end;

    procedure error;

    begin

    closegraph;

    writeln ('error!') ;

    end;

    begin

    write ('N = ') ;

    readln (n) ;

    randomize;

    init;

    if graphresult = 0 then

    begin

    for i:=1 to n do

    begin

    setcolor (random (14) + 1) ;

    x:=random (640) ;

    y:=random (480) ;

    height:=random (91) + 10;

    width:=random (101) + 20;

    rectangle (x, y, x+width, y+height) ;

    end;

    end else error;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу (Паскаль) построения на экране n прямоугольников разного цвета, расположенных хаотично. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы