Задать вопрос
24 сентября, 04:28

Написать программу, которая проверяет - имеется ли в записи натурального числа ноль.

Язык программирования паскаль.

+3
Ответы (1)
  1. 24 сентября, 05:24
    0
    Program red;

    var a, b, c:integer;

    begin

    b:=0;

    readln (a) ;

    if a<10 then

    begin

    if a*5=0 then b:=1;

    end;

    if (a>=10) and (a<100) then

    begin

    if ((a div 10) * 5=0) then b:=1;

    if ((a mod 10) * 5=0) then b:=1;

    end;

    if (a>=100) and (a<1000) then

    begin

    if ((a div 100) * 5=0) then b:=1;

    if (((a div 10) mod 10) * 5=0) then b:=1;

    if ((a mod 10) * 5=0) then b:=1;

    end;

    if b=1 then writeln ('yes') else writeln ('no') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая проверяет - имеется ли в записи натурального числа ноль. Язык программирования паскаль. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы