Задать вопрос
9 февраля, 05:42

Два неразлучных товарища решили вместе зарабатывать на жизнь и жить дружно всю жизнь до самой смерти. Устроившись на хорошую работу (целое случайное число до 1000 р. В день) решили все деньги, полученные ими в день, делить поровну, а если число получиться нечетное, то складывать остаток от деления их, опять таки, общую свинью-копилку. Составьте программу

+4
Ответы (1)
  1. 9 февраля, 09:22
    0
    Var a, b: integer

    c, e:longint;

    begin

    write ('введите количество прожитых дней друзьями-->') ;

    readln (b) ;

    for i:=b downto 0 do begin

    write ('сколько денег они заработали в этот день-->') ;

    readln (a) ;

    if a mod 2 = 0 then e: = a/2

    else c:=a;

    end;

    write ('заработал каждый из них за всю жизнь-->', e) ;

    write ('то что они смогли накопить за всю жизнь-->', a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Два неразлучных товарища решили вместе зарабатывать на жизнь и жить дружно всю жизнь до самой смерти. Устроившись на хорошую работу (целое ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы