Задать вопрос
2 августа, 16:18

Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом. На вход программе подается строка, состоящая не более чем из 255 символов. Выведите искомое число. паскаль

+4
Ответы (1)
  1. 2 августа, 17:14
    0
    Var s : String;

    Function isPali (ss : String) : Boolean;

    Begin

    If Length (ss) >0 then isPali: = (ss[1]=ss[Length (ss) ]) and isPali (Copy (ss, 2, Length (ss) - 2))

    else isPali:=True;

    end;

    Function NtoPali (ss : String) : Integer;

    Begin

    If isPali (ss) then NtoPali:=0 else NtoPali:=1+NtoPali (Copy (ss, 2, Length (ss) - 1)) ;

    end;

    Begin

    s:='abcdc'; / / Readln (s) ;

    Writeln (NtoPali (s)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы