Задать вопрос
2 мая, 17:57

В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат (номер спортсмена не связан с очередностью). Написать программу, которая выводит на экран номер и результат худшего и лучшего спортсменов. все это как то связанно с оператором повтора FOR

+5
Ответы (1)
  1. 2 мая, 18:36
    0
    Var a, b:array[1 ... 25] of integer;

    i, min, max:integer;

    begin

    max:=1;

    min:=1;

    for i:=1 to 25 do begin

    read (a[i]) ;

    read (b[i]) ;

    if a[i]>a[max] then max:=i;

    if a[i]
    end;

    writeln ('Лучший - ', a[max],' длина - ', b[max]) ;

    writeln ('Худший - ', a[min],' длина - ', b[min]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат (номер спортсмена не ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы