Задать вопрос
5 мая, 22:54

Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.

Входные данные

Входная строка содержит три целых числа, разделённых пробелами.

Выходные данные

Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

Примеры

входные данные

1 2 1

выходные данные

2

+4
Ответы (1)
  1. 6 мая, 00:56
    0
    Var

    a, b, c, d:longint;

    begin

    read (a, b, c) ;

    If a=b then inc (d) ;

    If a=c then inc (d) ;

    If b=c then inc (d) ;

    if d=1 then d:=2;

    writeln (d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные данные Входная строка содержит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы