Задать вопрос
21 января, 07:13

Помогите решить!

1))) Вводятся 4 числа: a, b, c и d.

Выведите все числа на отрезке от a до b, дающие остаток c при делении на d

Входные данные 1 4 1 2

выходные данные 1 3

Входные данный 1 5 0 4

выходные данные 4

2))) Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

входные данные 1 5

выходные данные 1 4

выходные данные 2 9

выходные данные 4 9

3))) Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < = x < = 30000).

входные данные 4

выходные данные 2

входные данные 5

выходные данные 5

+2
Ответы (1)
  1. 21 января, 09:57
    0
    Var a, b, c, d, i : integer;

    Begin

    read (a) ;

    read (b) ;

    read (c) ;

    read (d) ;

    for i : = a to b do

    if (i mod c = d) then

    writeln (i) ;

    writeln () ;

    for i : = a to b do

    if frac (sqrt (i)) = 0 then

    writeln (i) ;

    writeln () ;

    for i : = 2 to a-1 do

    if a mod i = 0 then begin

    writeln (i) ;

    exit;

    end;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы