Задать вопрос
25 апреля, 21:08

Помогите в паскале составить

прогу. если можно на уровне 9 го класса

Составить программу для вычисления значения функции на отрезке [a, b] с шагом 1.

+5
Ответы (1)
  1. 25 апреля, 23:13
    0
    Мы взяли функцию f (x) = sin (x) - 2*cos (x).

    В процедуру-функцию function можно вставлять любые функции

    program func;

    uses Crt;

    var a, b, x, y:real;

    function f (var x:real) : real;

    begin

    f:=sin (x) - 2*cos (x) ;

    end;

    begin

    ClrScr; {Очистка экрана}

    Write (' a = ') ; ReadLn (a) ;

    Write (' b = ') ; ReadLn (b) ;

    WriteLn;

    x:=a;

    while x<=b do

    begin

    y:=f (x) ;

    WriteLn ('y (', x:1:0, ') = ', y:4:2) ;

    x:=x+1;

    end;

    ReadLn;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите в паскале составить прогу. если можно на уровне 9 го класса Составить программу для вычисления значения функции на отрезке [a, b] ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы