Задать вопрос
24 октября, 05:47

Написать программу, которая подсчитывает количество четных индексов положительных элементов введенного с клавиатуры массива целых чисел.

+5
Ответы (2)
  1. 24 октября, 06:20
    0
    var

    a:array [1 ... 100] of integer;

    i, n, k:integer;

    begin

    write ('Razmer massiva: ') ; readln (n) ;

    k:=0;

    for i:=1 to n do begin

    write ('A[', i,'] = ') ; readln (a[i]) ;

    if (a[i]>0) and (i mod 2 = 0) then k:=k+1;

    end;

    writeln ('Kol-vo: ', k) ;

    readln;

    end.
  2. 24 октября, 07:39
    0
    a - массив из n элементов

    k - количество четных индексов положительных элементов

    i - цикловая переменная, также индекс элемента массива

    Язык программирования: Паскаль

    var

    a : array [1 ... 100] of integer;

    n, k, i : integer;

    begin

    k : = 0;

    readln (n) ;

    for i:=1 to n do

    begin

    readln (a [ i ]) ;

    if (i mod 2 = 0) and (a [ i ] > 0) then

    k : = k + 1;

    end;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая подсчитывает количество четных индексов положительных элементов введенного с клавиатуры массива целых чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы