Задать вопрос
26 мая, 09:09

Ограничение времени: 1 секунда.

Однажды Петя играл с младшей сестрой в кубики и решил построить ей домик

в форме куба. Для домика высотой в 2 кубика понадобилось 8 кубиков, для домика

высотой 3 кубика понадобилось 27 кубиков, а на домик высотой в 4 кубика не хватило

кубиков, и сестренка очень расстроилась. Петя решил, что прежде чем начинать строить,

нужно проверить, хватит ли кубиков на дом необходимого размера. Помогите вычислить

Пете необходимое число кубиков для постройки домика высотой в n кубиков.

Входные данные Единственная строка содержит одно целое число n (1 ⩽ n ⩽ 109) -

высота домика. Гарантируется, что в 30% тестов n ⩽ 1000, а в 60% тестов n ⩽ 106.

Результат Нужно вывести одно число - количество кубиков для постройки домика.

Пример

Исходные данные Результат

2 8

+3
Ответы (1)
  1. 26 мая, 09:42
    0
    Var

    a:longint;

    begin

    readln (a) ;

    writeln (a*a*a) ;

    end;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ограничение времени: 1 секунда. Однажды Петя играл с младшей сестрой в кубики и решил построить ей домик в форме куба. Для домика высотой в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы