Задать вопрос
23 февраля, 20:44

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов.

программа: Pascal ABC.

+2
Ответы (2)
  1. 23 февраля, 23:23
    0
    Const

    n = 25;

    var

    a: array[1 ... n] of integer;

    i, s: integer;

    begin

    Writeln ('Введите элементы массива') ;

    s : = 0;

    for i : = 1 to n do

    begin Read (a[i]) ; s : = s + a[i] end;

    Writeln ('Среднее значение элементов массива равно ', s/n)

    end.
  2. 23 февраля, 23:34
    0
    Var A:array[1 ... 25] of Integer;

    i:integer;

    S:real;

    begin

    Readln (N) ;

    For i:=1 to 25 do

    Readln (A[i]) ;

    For i:=1 to 25 do

    S:=S+A[i];

    S:=S/25;

    Writeln (S) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы