Задать вопрос
11 марта, 17:47

Составте программу на Pascal.

Сколько существует (невырожденных) треугольников периметра N с целыми длинами сторон? (Треугольник со сторонами a, b, c называется невырожденным, если из отрезков длины a, b, c его можно составить.)

Входные данные. С клавиатуры вводится число N (1<=N<=1000)

Выходные данные. Программа выводит число таких треугольников.

+5
Ответы (1)
  1. 11 марта, 20:23
    0
    Uses crt;

    var a, b, c, k, n:integer;

    Begin

    clrscr;

    Write ('n=') ; readln (n) ;

    k:=0;

    for a:=1 to n do

    for b:=a to n do

    for c:=b to n do

    if (c
    writeln (k,' treugolnikov') ;

    writeln;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составте программу на Pascal. Сколько существует (невырожденных) треугольников периметра N с целыми длинами сторон? (Треугольник со ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы