Задать вопрос
14 мая, 14:56

Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне. Напишите программу, подсчитывающую общую сумму всех денег, подаренных к - му дню рождения.

Формат входных данных

На вход программе подается единственное число.

Это в паскале

+2
Ответы (1)
  1. 14 мая, 17:36
    0
    Var

    i, s, k, n:integer;

    begin

    readln (n) ;

    s:=0; k:=0;

    for i:=1 to n do

    begin

    s:=2*s+i;

    k:=k+s;

    end;

    write ('Дядюшка подарил ', k,' долларов.') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Мой богатый дядюшка подарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы