Задать вопрос
7 июня, 00:18

В Турбо паскале Уже нужно

Составить программу для обработки массива содержащего 10 целых числе. Определить максимальный элемент массива. Выполнение каждого логического блока программы оформить в виде отдельных процедур

+5
Ответы (1)
  1. 7 июня, 02:34
    0
    Uses crt;

    var i, j, k, n, max:integer; a:array[1 ... 100] of integer;

    procedure rmassr;

    begin

    for i:=1 to n do

    a[i]:=random (10) ;

    end;

    procedure rmassy;

    begin

    for i:=1 to n do

    readln (a[i]) ;

    end;

    procedure maxe;

    begin

    max:=a[1];

    for i:=2 to n do begin

    if a[i] > max then max:=a[i];

    end;

    writeln ('max element = ', max) ;

    end;

    procedure wmass;

    begin

    for i:=1 to n do

    write (a[i],' ') ;

    writeln;

    end;

    begin

    clrscr;

    randomize;

    write ('Длина массива') ; readln (n) ;

    write ('1-random; 2 - в ручную ') ; readln (k) ;

    if k=1 then rmassr ()

    else rmassy () ;

    wmass () ;

    maxe () ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В Турбо паскале Уже нужно Составить программу для обработки массива содержащего 10 целых числе. Определить максимальный элемент массива. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы