Задать вопрос
1 декабря, 03:14

Напишите программу в Паскаль: Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне)

+5
Ответы (1)
  1. 1 декабря, 04:04
    0
    Program n1;

    var i, a, sum, k, p, n: integer;

    begin

    write ('введите кол-во чисел: ') ;

    readln (n) ;

    sum:=0;

    k:=0;

    p:=1;

    for i:=1 to n do

    begin

    write ('введите ', i,' число: ') ;

    readln (a) ;

    if (a mod 3=0) and (a mod 60)

    then

    begin

    sum:=sum+a;

    k:=k+1;

    end;

    if a mod 20 then p:=p*a;

    end;

    writeln ('сумма: ', sum) ;

    writeln ('количество: ', k) ;

    writeln ('произведение: ', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в Паскаль: Для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы