Задать вопрос
30 марта, 16:56

составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие

+4
Ответы (1)
  1. 30 марта, 17:51
    -2
    const

    s: array [1 ... 6] of char = ('б','в','г','д','ж','з') ;

    d: array [1 ... 6] of char = ('п','ф','к','т','ш','с') ;

    var

    c: string;

    i, j: integer;

    begin

    readln (c) ;

    for i: = 1 to length (c) do

    for j: = 1 to 6 do

    if d[j]=c[i] then c[i]: = s[j]

    else

    if s[j]=c[i] then c[i]: = d[j];

    writeln (c)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы