Задать вопрос
24 марта, 14:53

Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу признака конца.

+3
Ответы (1)
  1. 24 марта, 17:06
    0
    Var a, b, k, s:integer;

    Begin

    writeln ('Сколько всего будет чисел?') ;

    readln (a) ;

    writeln ('Вводите числа по одному через enter') ;

    for b:=1 to a do

    begin

    readln (k) ;

    if k>0 then S:=S+k;

    end;

    writeln (S/a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы