Задать вопрос
10 марта, 22:22

Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов, используя подпрограмму вычисления площади круга (два варианта: с процедурой и с функцией)

+2
Ответы (1)
  1. 11 марта, 01:45
    0
    Var

    r1, r2: real;

    procedure pCircleSquare (r: real; var S: real) ;

    begin

    s : = Pi * sqr (r) ;

    end;

    function fCircleSquare (r: real) : Real;

    begin

    fCircleSquare : = Pi * sqr (r) ;

    end;

    begin

    Write ('r1, r2 = ') ;

    ReadLn (r1, r2) ;

    writeln ('Функция S = ', abs (fCircleSquare (r1) - fCircleSquare (r2)) : 5:2) ;

    pCircleSquare (r1, r1) ;

    pCircleSquare (r2, r2) ;

    writeln ('Процедура S = ', abs (r1 - r2) : 5:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов, используя подпрограмму вычисления площади круга ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы