Задать вопрос
11 ноября, 10:15

Написать программу перевода целого двоичного десятиразрядного числа в десятичную систему

+1
Ответы (1)
  1. 11 ноября, 12:51
    0
    {

    Перевод двоичного числа в десятичное.

    Символы, отличающиеся от 0 и 1, заменяются нулями.

    Программа будет работать некорректно при вводе

    более 31 знака.

    }

    var

    bin:string;

    i, d:integer;

    p, dec:longint;

    begin

    Write ('Введите двоичное число: ') ; Read (bin) ;

    dec:=0;

    p:=1;

    for i:=Length (bin) downto 1 do

    begin

    if bin[i]='1' then d:=1 else d:=0;

    dec:=dec+d*p; p:=2*p

    end;

    Writeln ('Десятичный эквивалент: ', dec)

    end.

    Тестовое решение:

    Введите двоичное число: 1011011001

    Десятичный эквивалент: 729
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу перевода целого двоичного десятиразрядного числа в десятичную систему ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы