Задать вопрос
22 апреля, 07:27

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

Входные данные:

Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:

В выходной поток вывести 'YES' или 'NO'.

Пример входного файла

5 4 5

Пример выходного файла

YES

+5
Ответы (1)
  1. 22 апреля, 08:50
    0
    Var a, b, c:real;

    begin

    writeln ('Vvedite 3 chisla') ;

    readln (a, b, c) ;

    if (a>=b) and (a>=c) then

    writeln ('yes') elso

    writeln ('no') ;

    end.

    примерно так, могут быть ошибки, но алгоритм ясен
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат. Входные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы