Задать вопрос
17 октября, 20:47

Дана строка, состоящая из 50 символов. Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог 'ea'.

+2
Ответы (1)
  1. 17 октября, 21:21
    0
    Var s:string; k:integer;

    procedure SubInc (var s:string; var k:integer) ;

    begin;

    while pos ('ea', s) 0 do

    begin;

    delete (s, pos ('ea', s),2) ;

    inc (k) ;

    end;

    end;

    begin;

    readln (s) ;

    if length (s) 10 then exit;

    SubInc (s, k) ;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана строка, состоящая из 50 символов. Составьте программу, используя процедуру которая определяет сколько раз встречается в строке слог ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы