Задать вопрос
6 марта, 20:48

Авиакомпания перевезла в первый год 21 тыс. пассажиров. Каждый следующий год увеличила перевозки на 4%. Сколько тыс. пассажиров перевезено за 5 лет? Через

сколько лет удвоится пассажиропоток.

Помогите с задаче по информатике, напишите программу.

+3
Ответы (1)
  1. 6 марта, 22:33
    0
    Var n, s, k:integer;

    begin

    / / 1

    n:=21000;

    s:=n;

    for k:=2 to 5 do

    begin

    n:=round (n*1.04) ;

    s:=s+n;

    end;

    writeln ('s = ', s) ;

    / / 2

    n:=21000; k:=1;

    while n<2*21000 do

    begin

    n:=round (n*1.04) ;

    k:=k+1;

    end;

    writeln ('k = ', k,' n = ', n) ;

    end.

    Результат:

    s = 113745

    k = 19 n = 42544
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Авиакомпания перевезла в первый год 21 тыс. пассажиров. Каждый следующий год увеличила перевозки на 4%. Сколько тыс. пассажиров перевезено ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы