Задать вопрос
15 сентября, 10:57

Напишите программу (Паскаль) :

выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке.

например:

1. информатика

2. химия

3. математика

4. физкультура

5. литература

Вывод: 1. информатика

5. литература

3. математика

4. физкультура

2. химия

+1
Ответы (1)
  1. 15 сентября, 12:55
    0
    Uses crt;

    const n=5;

    var

    s:array[1 ... n] of string;

    i, j, c:integer;

    ss:string;

    begin

    writeln ('Введите : ') ;

    for i:=1 to n do begin

    write ('s[', i,']=') ;

    readln (s[i]) ;

    end;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if s[i]>s[j] then

    begin

    ss:=s[i];

    s[i]:=s[j];

    s[j]:=ss;

    end;

    for i:=1 to n do

    writeln (i,'.', s[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу (Паскаль) : выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы