Задать вопрос
15 сентября, 06:55

Помогите, плесс.

на языке паскаля.

напишите программу, которая в последовательности натуральных чисел определяет минимальное, оканчивающееся на 2. Программа получает числа. Признак окончания ввода 0. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число - минимальное, оканчивающееся на 2, если таких нет, вывести на экран об этом сообщение.

+4
Ответы (1)
  1. 15 сентября, 10:19
    0
    Var

    A, m:integer;

    Begin

    m:=32767;

    Repeat

    Read (A) ;

    if (A mod 10 = 2) and (A < m) then m:=A;

    Until A=0;

    if m mod 2 = 0 then WriteLn (m)

    else WriteLn ('Чисел, оканчивающихся двойкой нет.')

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите, плесс. на языке паскаля. напишите программу, которая в последовательности натуральных чисел определяет минимальное, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Новые вопросы по информатике