Задать вопрос
20 апреля, 15:52

Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива

+3
Ответы (1)
  1. 20 апреля, 19:13
    0
    Если паскаль, то -

    const n:=100; / / в массиве пусть будет 100 элементов

    var tarray:array[1 ... n] of integer;

    max:integer;

    i:=byte;

    begin

    {тут заполнение массива}

    max:=tarray[1]; / / думаем что максимум - это первый элемент

    for i:=1 to n do

    if max > tarray[i]

    then max:=tarray[i]; //если встречаем элемент больше максимального - то он - новый максимальный

    write ('Максимальный элемент - ', max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы