Задать вопрос
4 октября, 09:06

Условие этой задачи очень простое. Найдите наименьшее K такое, что K! делится на N без

остатка. K! = 1 · 2 · 3 · ... · (K - 1) · K.

Формат входных данных

В первой и единственной строке дано число N (1 ⩽ N ⩽ 109).

+3
Ответы (1)
  1. 4 октября, 09:37
    0
    Var k, n, d, m, s:integer;

    begin

    k : = 1;

    d : = 2;

    read (n) ;

    while n > 1 do

    begin

    s : = 0;

    m : = 1;

    while n mod d = 0 do

    begin

    if m mod d 0 then

    begin

    s : = s + d;

    m : = s;

    end;

    n : = n div d;

    m : = m div d;

    end;

    if s > k then k : = s;

    d : = d + 1

    end;

    writeln (k)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Условие этой задачи очень простое. Найдите наименьшее K такое, что K! делится на N без остатка. K! = 1 · 2 · 3 · ... · (K - 1) · K. Формат ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы