Задать вопрос
19 декабря, 00:44

Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)

+5
Ответы (1)
  1. 19 декабря, 01:04
    0
    Var

    a, chislo, t:longint;

    c, nov, posl:integer;

    begin

    readln (a) ;

    posl:=a mod 10;

    chislo:=a;

    t:=1;

    repeat

    a:=a div 10;

    t:=t*10;

    until a<10;

    chislo:=chislo mod t;

    chislo:=posl*t+chislo-posl+a;

    writeln (chislo) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы