Задать вопрос
30 апреля, 12:17

Написать программу на Pascal ABC. Дано

предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы

"и", стоящие на четных местах.

+1
Ответы (1)
  1. 30 апреля, 15:55
    0
    Var

    str : string;

    i, count : integer;

    begin

    {часть 1 - обратный порядок}

    write ('Введите строку: ') ;

    readln (str) ;

    write ('Результат: ') ;

    for i : = length (str) downto 1 do

    write (str[i]) ;

    {часть 2 - считаем "и"}

    count : = 0;

    for i : = 1 to length (str) do

    if (str[i] = 'и') and (i mod 2 = 0) then

    count : = count + 1;

    writeln; {переходим на следующую строку}

    for i : = 1 to count do

    writeln ('и') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Pascal ABC. Дано предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы "и", стоящие на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы