Задать вопрос
20 декабря, 01:16

Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд.

В чем ошибка?

program upr4;

var n, m, i:longint;

a, b, c, e, f, k: integer;

begin

m:=0;

for i: = 100000 to 999999 do begin

k: = n mod 10;

f: = (n div 10) mod 10;

e: = (n div 100) mod 10;

c: = (n div 1000) mod 10;

b: = (n div 10000) mod 10;

a: = (n div 100000) mod 10;

if k+f+e=a+b+c

then m:=m+1

else m:=m; end;

writeln (m) ;

end.

+1
Ответы (1)
  1. 20 декабря, 01:26
    0
    Для начала - откуда взялась переменная n?
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы