Задать вопрос
2 сентября, 18:26

составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.

+5
Ответы (2)
  1. 2 сентября, 22:10
    0
    Program gt;

    var n, s:integer;

    begin

    readln (n) ;

    s: = (n div 100) + (n div 10) mod 10 + (n mod 10) ;

    writeln (s) ;

    end.

    каждая скобка это 1 2 3 цифра соответсвенно
  2. 2 сентября, 22:19
    0
    Var a, N, sum:word;

    begin

    Read (N) ;

    Sum:=0;

    While N0 do

    begin

    a:=N mod 10;

    N:=N div 10;

    Sum:=sum+a;

    end;

    Write (sum) ;

    end.

    Или по-простому еще так:

    Var a, b, c, N:word;

    begin

    Read (N) ;

    a:=N mod 10;

    b: = (N mod 100) div 10;

    c:=N div 100;

    Write (a+b+c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы