Задать вопрос
29 сентября, 22:53

Население города увеличивается на от 1.5% до 3.5% каждый год. Каждый же год, по ряду причин фиксируется убыль населения от 0.5% до 3%, 2016 году население составляло 347000.

Напишите программу, которая выведет на экран предсказываемую численость населения города в каждом году вплоть до 2025.

Определить в каком году был наибольшие прирост и убыль населения!

+4
Ответы (1)
  1. 30 сентября, 01:03
    0
    Var n, p, m, max1, max2, im1, im2, i:integer;

    begin

    Randomize;

    n:=347000;

    max1:=0; max2:=0;

    for i:=2017 to 2025 do

    begin

    p:=round (n * (2*random+1.5) / 100) ;

    m:=round (n * (2.5*random+0.5) / 100) ;

    if p>max1 then begin max1:=p; im1:=i; end;

    if m>max2 then begin max2:=p; im2:=i; end;

    n:=n+p-m;

    writeln (i,': n = ', n) ;

    end;

    writeln ('Наибольший прирост = ', max1,', ', im1,' год') ;

    writeln ('Наибольшая убыль = ', max2,', ', im2,' год') ;

    end.

    Пример:

    2017: n = 345558

    2018: n = 349922

    2019: n = 353532

    2020: n = 356979

    2021: n = 364842

    2022: n = 371614

    2023: n = 381020

    2024: n = 389903

    2025: n = 388485

    Наибольший прирост = 11702, 2023 год

    Наибольшая убыль = 10701, 2020 год
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Население города увеличивается на от 1.5% до 3.5% каждый год. Каждый же год, по ряду причин фиксируется убыль населения от 0.5% до 3%, 2016 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы