Задать вопрос
13 ноября, 08:03

составьте программу, которая заполняет массив случайными целыми числами в диапозоне от 1 до 100, затем меняет местами наименьший четный элемент с наибольшим нечетным элементом

+5
Ответы (1)
  1. 13 ноября, 10:51
    0
    Program Pr1;

    uses crt;

    var mas:array[1 ... 10] of integer;

    i, max, min, a, b:integer;

    Begin

    clrscr;

    max:=0;

    min:=150;

    randomize;

    for i:=1 to 10 do mas[i]:=1+random (100) ;

    for i:=1 to 10 do write (mas[i]) ;

    for i:=1 to 10 do begin if (mas[i] mod 2=0) and (mas[i]>max) then begin

    max:=mas[i];

    a:=i;

    end;

    if (mas[i] mod 2=0) and (mas[i]
    min:=mas[i];

    b:=i;

    end;

    end;

    i:=mas[a];

    mas[a]:=mas[b];

    mas[b]:=i;

    writeln () ;

    for i:=1 to 10 do write (mas[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составьте программу, которая заполняет массив случайными целыми числами в диапозоне от 1 до 100, затем меняет местами наименьший четный ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы