Задать вопрос
26 декабря, 20:33

Напишите программу паскаль: С клавиатуры вводится число от 0 до 1000 включительно. Каждая цифра не превосходит 6. Найти сумму промежуточных значений между наибольшей и наименьшей цифрами в числе?

+2
Ответы (1)
  1. 26 декабря, 22:28
    0
    Попробуй, может сработает)

    program num32; var

    nums, i, min, max, a, i2, i3, sum: integer; begin

    min : = 7;

    max : = 0;

    sum : = 0;

    readln (nums) ;

    while nums 0 do

    begin

    if (((nums mod 10) > max)) then begin

    max : = nums mod 10;

    end;

    if (((nums mod 10) < min)) then begin

    min : = nums mod 10;

    end;

    nums : = nums div 10;

    end;

    if (min > max) then begin

    for i2 : = max to min do

    sum : = sum + i2;

    end;

    if (max > min) then begin

    for i2 : = min to max do

    sum : = sum + i2;

    end;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу паскаль: С клавиатуры вводится число от 0 до 1000 включительно. Каждая цифра не превосходит 6. Найти сумму промежуточных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы