Задать вопрос
18 июля, 13:02

Помогите записать задачу в Turbo Pascalе

Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить:

а) В какой день он пробежит больше 20 км

б) В какой день суммарный пробег за все дни превысит 100 км

+4
Ответы (1)
  1. 18 июля, 13:28
    0
    program ncdkj;

    uses crt;

    var a, b, p, d, sd:integer;

    begin

    clrscr;

    a:=10;

    b:=10;

    d:=1;

    sd:=1;

    p:=10*0,1;

    repeat

    a:=a+p;

    d:=d+1;

    until a>20;

    repeat

    b:=b+p;

    sd:=sd+1;

    s:=s+b;

    until s>100;

    case sd mod 7 of

    0:writeln ('сумма 100 км в 7') ;

    1:writeln ('сумма 100 км в 1') ;

    2:writeln ('сумма 100 км в 2') ; И так до шести

    case d mod 7 of

    0:writeln ('20 км в 7') ;

    1:writeln ('20 км в 1') ;

    2:writeln ('20 км в 2') ; И так до шести

    readln;

    end.

    Надеюсь второе правильно понял, вроде должно работать
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего.
Ответы (1)
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок. Написать программу в Pascal
Ответы (1)
Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а) в какой день он пробежал больше 20 км.
Ответы (1)
Написать код в программе C#: 1 задание: Начав тренировки, лыжник в первый день пробежал 7 км. Каждый следующий день он увеличивал пробег на 12% от пробега предыдущего дня.
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)