Задать вопрос
2 января, 05:48

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать программу на массивах размерностью 5 и 10 элементов

+3
Ответы (1)
  1. Ф
    2 января, 07:18
    0
    var i, N:integer;

    Min:real;

    mas:array[0 ... 100]of real;

    beegin

    write ('введите N') ;

    read (N) ;

    {for i:=1 to N do begin

    mas[i]:=random (50) ; write (mas[i],' ') ; end;

    или

    for i:=1 to N do

    read (mas[i]) ;

    for i:=1 to N do

    write (mas[i],' ') ; }

    min:=mas[0];

    for i:=0 to N do

    if min
    writeln;

    for i:=1 to N do begin

    mas[i]:=mas[i]/min; write (mas[i]) ; end;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Войти
Задать вопрос