Задать вопрос
27 мая, 13:04

Решить уравнение ax^3+bx для произвольных a, b. Составить программу на Паскале.

+5
Ответы (1)
  1. 27 мая, 13:11
    0
    Var a, b: real;

    begin

    readln (a, b) ;

    if a=0 then if b = 0 then writeln ('x - любое значение')

    else writeln ('x1 = 0') ;

    if a>0 then if (b>=0) then writeln ('x1 = 0')

    else writeln ('x1=0 ', 'x2=',-sqrt (-b/a),' ', 'x3=', sqrt (-b/a)) ;

    if a<0 then if (b<=0) then writeln ('x1 = 0')

    else writeln ('x1=0 ', 'x2=',-sqrt (b/-a),' ', 'x3=', sqrt (b/-a))

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить уравнение ax^3+bx для произвольных a, b. Составить программу на Паскале. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы