Задать вопрос
10 августа, 09:05

составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а остальные увеличивает на 3. На экран выводятся исходные и преобразованные значения

+5
Ответы (1)
  1. 10 августа, 12:39
    0
    var

    a: array [1 ... 15] of integer; / / Массив из 15 целых чисел

    i: integer;

    begin

    randomize;

    write ('Исходный массив: ') ;

    for i: = 1 to 15 do {Заполняем массив случайными целыми числами в промежутке [3; 33] и распечатываем его}

    begin

    a[i]: = random (31) + 3;

    write (a[i], ' ') ;

    end;

    writeln;

    write ('Преобразованный массив: ') ;

    for i: = 1 to 15 do {Если элемент нечетный, то заменяем его на 1, иначе увеличивам его на 3 и распечатываем полученный массив}

    begin

    if a[i] mod 2 = 0 then a[i]: = 1

    else a[i]: = a[i] + 3;

    write (a[i], ' ') ;

    end;

    writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

    end.

    Если все правильно, отметь решение как лучшее)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3,33]. Нечетные числа заменяет на 1, а ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы